Elevated Error Rates
Incident Report for AngelList
Resolved
This incident has been resolved.
Posted about 1 month ago. May 25, 2018 - 22:15 UTC
Investigating
We are seeing an elevated rate of errors for a small percentage of users. Reloading the affected pages may resolve the issue.
Posted about 1 month ago. May 25, 2018 - 06:56 UTC
This incident affected: AngelList.com.