Elevated error rate
Incident Report for AngelList
Resolved
This incident has been resolved.
Posted 5 months ago. May 31, 2017 - 18:18 UTC
Investigating
We are seeing an elevated rate of errors at the moment. We are looking into this.
Posted 5 months ago. May 31, 2017 - 17:57 UTC